Home World Forum
Stars! AutoHost web forums

Jump to Stars! AutoHost


 
 
Home » Stars! 2.6/7 » Questions about Stars! AutoHost » Login needed on every visit ?
icon5.gif  Login needed on every visit ? Sun, 16 December 2012 16:48 Go to next message
craebild is currently offline craebild

 
Lieutenant

Messages: 568
Registered: December 2003
Location: Copenhagen, Denmark
Suddenly I need to log in every time I visit the forum, not only if it has been more than 24 hours since my last login. I think it changed Friday, but it could also be Saturday.

I haven't changed anything in the configuration of my browser (Firefox 17.0.1), and I haven't seen any change in the other forum I visit - But that other forum does not require me to login again at intervals, in that other forum I can be logged in every time I visit, no matter how long time it has been since my last login.

Has anyone else seen that problem ?



Med venlig hilsen / Best regards / Mit freundlichen Grüßen
Christian Ræbild / Christian Raebild

Report message to a moderator

Re: Login needed on every visit ? Mon, 17 December 2012 09:47 Go to previous messageGo to next message
XAPBob is currently offline XAPBob

 
Lt. Commander

Messages: 957
Registered: August 2012
Not every time, but on some devices it seems to be alot less than a 24hr timeout

Report message to a moderator

Re: Login needed on every visit ? Mon, 17 December 2012 11:39 Go to previous messageGo to next message
craebild is currently offline craebild

 
Lieutenant

Messages: 568
Registered: December 2003
Location: Copenhagen, Denmark
I lust logged in, looked at this thread, then shut down my browser, restarted my browser, went to the forum again, and I had to log in again.

If that is a timeout, then it is a timeout of a few seconds.

PS: I am still not getting notifications of posts in threads I have asked for notifications for.



Med venlig hilsen / Best regards / Mit freundlichen Grüßen
Christian Ræbild / Christian Raebild

Report message to a moderator

Re: Login needed on every visit ? Tue, 18 December 2012 15:01 Go to previous messageGo to next message
donjon is currently offline donjon

 
Lt. Commander

Messages: 808
Registered: November 2002
Location: Benque Viejo del Carmen, ...

Firefox?

What OS??

I know the firefox in Ubuntu is configured to discard everything when the browser restarts...

regards,
dj


[Updated on: Wed, 19 December 2012 10:39]

Report message to a moderator

Re: Login needed on every visit ? Tue, 18 December 2012 22:39 Go to previous messageGo to next message
Ron is currently offline Ron

 
Commander
Forum Administrator
Stars! AutoHost Administrator

Messages: 1232
Registered: October 2002
Location: Collegedale, TN
I have not made any changes.


Ron Miller
Stars! AutoHost

Report message to a moderator

Re: Login needed on every visit ? Wed, 19 December 2012 10:40 Go to previous messageGo to next message
donjon is currently offline donjon

 
Lt. Commander

Messages: 808
Registered: November 2002
Location: Benque Viejo del Carmen, ...

Hi,

I'm quite sure its a local problem. Not a configuration change on the server.

regards,
dj

Report message to a moderator

Re: Login needed on every visit ? Wed, 19 December 2012 12:06 Go to previous messageGo to next message
craebild is currently offline craebild

 
Lieutenant

Messages: 568
Registered: December 2003
Location: Copenhagen, Denmark
OS is Windows 7 Pro 64 bit.

If it is a local problem, then there must be something preventing the cookie from being written, but as I said, I haven't changed anything. Must have been some automatic update, I will have to see if I can find out what it is.



Med venlig hilsen / Best regards / Mit freundlichen Grüßen
Christian Ræbild / Christian Raebild

Report message to a moderator

Re: Login needed on every visit ? Wed, 19 December 2012 12:29 Go to previous messageGo to next message
skoormit is currently offline skoormit

 
Lieutenant

Messages: 665
Registered: July 2008
Location: Alabama
craebild wrote on Wed, 19 December 2012 11:06
OS is Windows 7 Pro 64 bit.

If it is a local problem, then there must be something preventing the cookie from being written, but as I said, I haven't changed anything. Must have been some automatic update, I will have to see if I can find out what it is.


Same thing happens to me in Win 7 Enterprise 64 bit. If I close Firefox and reopen immediately, I have to re-login. Never happens with Chrome.

Also: Logging in on one browser (FF or Chrome) causes my account to be logged out on the other one.

And I never receive any email notifications, but that's probably not related to the browser issue.



What we need's a few good taters.

Report message to a moderator

Re: Login needed on every visit ? Wed, 19 December 2012 14:38 Go to previous messageGo to next message
skoormit is currently offline skoormit

 
Lieutenant

Messages: 665
Registered: July 2008
Location: Alabama
The re-login is no longer happening when I close and reopen Firefox.

I have not changed any system or browser settings.

I did update and confirm my profile's email address. Possibly related?



What we need's a few good taters.

Report message to a moderator

Re: Login needed on every visit ? Wed, 19 December 2012 17:49 Go to previous messageGo to next message
donjon is currently offline donjon

 
Lt. Commander

Messages: 808
Registered: November 2002
Location: Benque Viejo del Carmen, ...

Are you sure it was confirmed?

Report message to a moderator

Re: Login needed on every visit ? Wed, 19 December 2012 20:34 Go to previous messageGo to next message
skoormit is currently offline skoormit

 
Lieutenant

Messages: 665
Registered: July 2008
Location: Alabama
donjon wrote on Wed, 19 December 2012 16:49
Are you sure it was confirmed?


I am 100% positive that I clicked the confirmation link that was emailed to my address, and that the forum then re-activated my account. Is there more to it than that?



What we need's a few good taters.

Report message to a moderator

Re: Login needed on every visit ? Thu, 20 December 2012 18:04 Go to previous messageGo to next message
donjon is currently offline donjon

 
Lt. Commander

Messages: 808
Registered: November 2002
Location: Benque Viejo del Carmen, ...

Not as far as I know Smile
But your browser is not caching the username/password associated with ahf...
If its not a registration problem then it must be cofiguration of the browser.

I assure you that I rarely log in... maybe once every two days. (or after a reboot) I use firefox.

Report message to a moderator

Re: Login needed on every visit ? Fri, 21 December 2012 11:19 Go to previous messageGo to next message
skoormit is currently offline skoormit

 
Lieutenant

Messages: 665
Registered: July 2008
Location: Alabama
The problem started for me late last week and went away for me on Wednesday. I never changed any browser settings. Although possibly Firefox iterated through an update.

I do have one new problem: my forum status bar says I have 1 unread private message, but my inbox is empty.

And one continuing problem: I never receive notification emails, and I never see notifications on the Notifications page.



What we need's a few good taters.

Report message to a moderator

notifications Fri, 21 December 2012 19:14 Go to previous messageGo to next message
Altruist is currently offline Altruist

 
Commander

Messages: 1068
Registered: August 2005
Location: Berlin
skoormit wrote on Fri, 21 December 2012 17:19
And one continuing problem: I never receive notification emails, and I never see notifications on the Notifications page.


I think I have the same problem. I have subscribed to several forums, one of them "Fledgling Admirals" in which there were several posts in the last week... but I got no notifications.

Could it be that some connection is broken due to the new forum and the new URLs (sahforum2...)? On the other hand the links to my subsriptions in the
Control Panel -> Subscriptions
seem to be valid and working ones.

Report message to a moderator

Re: notifications Fri, 21 December 2012 22:38 Go to previous messageGo to next message
skoormit is currently offline skoormit

 
Lieutenant

Messages: 665
Registered: July 2008
Location: Alabama
Altruist wrote on Fri, 21 December 2012 18:14
skoormit wrote on Fri, 21 December 2012 17:19
And one continuing problem: I never receive notification emails, and I never see notifications on the Notifications page.


I think I have the same problem. I have subscribed to several forums, one of them "Fledgling Admirals" in which there were several posts in the last week... but I got no notifications.

Could it be that some connection is broken due to the new forum and the new URLs (sahforum2...)? On the other hand the links to my subsriptions in the
Control Panel -> Subscriptions
seem to be valid and working ones.


I got a notification for your post, Altruist. So maybe it's fixed?



What we need's a few good taters.

Report message to a moderator

Re: notifications Sat, 22 December 2012 03:00 Go to previous messageGo to next message
craebild is currently offline craebild

 
Lieutenant

Messages: 568
Registered: December 2003
Location: Copenhagen, Denmark
Firefox is caching my user name and password, so I am just clicking the login button to log in, but I have to do that every time, which is a minor annoyance.

Until now, that is. This time I got to the login page when I clicked the login button on the main forum page, as if there wasn't any cached user name and/or password, though the cached user name certainly was there. On the login page I re-entered my password to be certain the password was correct, so I don't know whether trying to use the cached password there would have worked.

And as I mentioned earlier, I am not receiving any notification e-mails.



Med venlig hilsen / Best regards / Mit freundlichen Grüßen
Christian Ræbild / Christian Raebild

Report message to a moderator

Re: notifications Sat, 22 December 2012 15:48 Go to previous messageGo to next message
donjon is currently offline donjon

 
Lt. Commander

Messages: 808
Registered: November 2002
Location: Benque Viejo del Carmen, ...

craebild wrote on Sat, 22 December 2012 02:00
Firefox is caching my user name and password, so I am just clicking the login button to log in, but I have to do that every time, which is a minor annoyance.

Until now, that is. This time I got to the login page when I clicked the login button on the main forum page, as if there wasn't any cached user name and/or password, though the cached user name certainly was there. On the login page I re-entered my password to be certain the password was correct, so I don't know whether trying to use the cached password there would have worked.

And as I mentioned earlier, I am not receiving any notification e-mails.


Ah, gotcha Smile
Yes, I have the same action which is occurring here... I do need to log in every couple of days (the username/password is cached but i need to click on "log in")

As far as notifications go, I get notifications rarely... I just checked my records and the last one which came in was Nov. 16... and I was involved in a few other conversations... but this sporadic behaviour has been around for quite some time.

regards,
dj

Report message to a moderator

Re: notifications Sun, 23 December 2012 01:44 Go to previous messageGo to next message
craebild is currently offline craebild

 
Lieutenant

Messages: 568
Registered: December 2003
Location: Copenhagen, Denmark
donjon, if you only have to login every couple of days, then it isn't the same behaviour as I have. I have to click that login button every time, even if it has been less than a minute since last time I logged in.

Except that this time I didn't have to click the login button, so apparently the cookie was recognized this time.

But I am still not receiving any notification e-mails, and as you say that problem has been there for a while.



Med venlig hilsen / Best regards / Mit freundlichen Grüßen
Christian Ræbild / Christian Raebild

Report message to a moderator

Re: Login needed on every visit ? Fri, 29 March 2013 10:35 Go to previous messageGo to next message
Altruist is currently offline Altruist

 
Commander

Messages: 1068
Registered: August 2005
Location: Berlin
Mmmh, after having typed in my login and password for about 50 times (just this year)... I am not looking forward to do it another 200 times this year.

Can't we change it that only once a month a relogin is needed? Still 12x/year to type stupid login stuff.

After all this is not my bank account but a game forum.

Report message to a moderator

Re: Login needed on every visit ? Fri, 29 March 2013 13:00 Go to previous messageGo to next message
nmid

 
Commander

Messages: 1608
Registered: January 2011
Location: GMT +5.5

In direct response to the main question you asked, even if the timeout is increased, it might not help
1. If you re-login from another ip/browser/device.
2. if you have a dynamic ip

As skoormit found out in Dec, if you log in from one browser, and then log in from another (even if it's on the same computer), you get logged out from the 1st browser.

A helpful question that might solve your problem, would be whether you have the password saved in your browser?
Which browser do you use and are you ok with your password being 'remembered' by it? If it's not a shared computer, it might not be a problem..

Anecdotally, I have my password saved on a shared home pc, because to be honest, I don't really think anyone would even visit the log in page or if they do, they won't even log in, or if they do, they just won't be interested in posting Very Happy


[Updated on: Fri, 29 March 2013 13:09]




I know my minefields.. but I'm a chaff sweeper.
I used to curse when I got stuck in traffic... till I realised I AM traffic.

Report message to a moderator

Re: Login needed on every visit ? Wed, 22 May 2013 09:36 Go to previous messageGo to next message
Altruist is currently offline Altruist

 
Commander

Messages: 1068
Registered: August 2005
Location: Berlin
nmid wrote on Fri, 29 March 2013 18:00

A helpful question that might solve your problem, would be whether you have the password saved in your browser?
Which browser do you use and are you ok with your password being 'remembered' by it? If it's not a shared computer, it might not be a problem..


Thanks. That helped.
Oldfashioned me had, of course, never used the password save option of the browser but there is really no reason not to do it for a simple game forum.

Report message to a moderator

Re: Login needed on every visit ? Wed, 04 March 2015 11:55 Go to previous messageGo to next message
XAPBob is currently offline XAPBob

 
Lt. Commander

Messages: 957
Registered: August 2012
Hmm - I'm really confused now...

I can't log in under chrome at all (mac or linux)
I can log in under safari (Mac or iOS)
I can login under chrome on iOS (although I *think* that is a skin on the safari engine)

I therefore know that I have the correct password, and the same pattern is repeated despite clearing cookies, and yes they are allowed for SAH.

I'm just confused now Confused

Report message to a moderator

Re: Login needed on every visit ? Wed, 04 March 2015 14:37 Go to previous messageGo to next message
skoormit is currently offline skoormit

 
Lieutenant

Messages: 665
Registered: July 2008
Location: Alabama
XAPBob wrote on Wed, 04 March 2015 10:55
Hmm - I'm really confused now...

I can't log in under chrome at all (mac or linux)
I can log in under safari (Mac or iOS)
I can login under chrome on iOS (although I *think* that is a skin on the safari engine)

I therefore know that I have the correct password, and the same pattern is repeated despite clearing cookies, and yes they are allowed for SAH.

I'm just confused now Confused


Problems here as well:
Login does not work in Chrome. No error given; the current page just reloads in the same (logged out) state.
Login works just fine in Firefox.



What we need's a few good taters.

Report message to a moderator

Re: Login needed on every visit ? Wed, 04 March 2015 23:10 Go to previous messageGo to next message
neilhoward

 
Commander

Messages: 1112
Registered: April 2008
Location: SW3 & 10023
Does this happen for both the log in page and the log in next to search?

Are you using VPN?

Report message to a moderator

Re: Login needed on every visit ? Thu, 05 March 2015 12:18 Go to previous messageGo to previous message
XAPBob is currently offline XAPBob

 
Lt. Commander

Messages: 957
Registered: August 2012
Yes and no respectively

Report message to a moderator

Previous Topic: Inactive + email
Next Topic: Can i get wiki access?
Goto Forum:
  


Current Time: Tue Jun 18 21:21:23 EDT 2024