Home World Forum
Stars! AutoHost web forums

Jump to Stars! AutoHost


 
 
Home » Stars! 2.6/7 » Questions about Stars! AutoHost » Turn gen problem
Turn gen problem Fri, 10 September 2010 12:33 Go to next message
Marduk is currently offline Marduk

 
Ensign

Messages: 345
Registered: January 2003
Location: Dayton, OH
The previous turn of the game AR at Play had a problem. When the turn generated, one of the players was counted as having submitted his file for the next turn. The time stamp was the same as the turn gen time. Something similar happened a while ago in a game I am playing, Topeka. I assumed some sort of AutoHost glitch but for some reason it didn't occur to me to look into it.

My guess is that the old file somehow failed to delete after the turn generation, and since it was already checked when it was originally submitted there is no reason for the game page to check it again to make sure it is for the correct turn. A turn file would fail to delete if there were an open connection to it at the time the deletion was attempted. That could be because something is currently looking at the file (Stars! executable or the backup procedure, I expect), or more likely because the operating system hasn't yet released the handle to the file - sometimes that can take a while or even fail to happen at all.

I recommend that players look at the game page when they get their turn file to check for this. Better to catch it ahead of time if you can.



One out of five dentists recommends occasional random executions to keep the peasants cowed and servile.

Report message to a moderator

Re: Turn gen problem Sun, 12 September 2010 05:24 Go to previous messageGo to next message
Micha

 

Messages: 2342
Registered: November 2002
Location: Belgium GMT +1
Happend to me several times. Smile It happens when you upload (multiple times) close to gen time. The game page only refreshes every 3 minutes, so it is possible it accepts an .x file while in fact the script already genned the new files. That new .x file is not deleted and the turn will show as "in".
You'll notice upload time will be very close to the gen time.

mch

Report message to a moderator

Re: Turn gen problem Tue, 14 September 2010 16:25 Go to previous messageGo to next message
mazda is currently offline mazda

 
Lieutenant

Messages: 655
Registered: April 2003
Location: Reading, UK
Odd that this should happen reasonably close together in two different games (also in Anything Goes).
Previous gen where the "problem" occurred, if it was this problem, was on Thursday 9th.
I expect it is just one of those coincidences.

Report message to a moderator

Re: Turn gen problem Tue, 14 September 2010 17:04 Go to previous message
Micha

 

Messages: 2342
Registered: November 2002
Location: Belgium GMT +1
mazda wrote on Tue, 14 September 2010 22:25

Odd that this should happen reasonably close together in two different games (also in Anything Goes).
Previous gen where the "problem" occurred, if it was this problem, was on Thursday 9th.
I expect it is just one of those coincidences.

Anything Goes' problem was even more fun! The second upload of the .x file was at the exact minute and second the game genned. Nod
This caused the diamond *not* to turn green (contrary to usual double uploads) but the .x file was *not* deleted either! So when the penultimate player uploaded the script found all .x files to be present! The old .x file got marked "wrong year" and therefor was not used, however the player was not marked as missing a turn.
Silly hair
Hit Computer

mch

Report message to a moderator

Previous Topic: Serial number questions
Next Topic: Game definition files
Goto Forum:
  


Current Time: Wed Jul 17 19:35:18 EDT 2024