Home World Forum
Stars! AutoHost web forums

Jump to Stars! AutoHost


 
 
Home » Stars! Clones, Extensions, Modding » Stars! Nova - Development » Can not launch client with a new game
Can not launch client with a new game Tue, 14 February 2012 02:59 Go to next message
Daniel is currently offline Daniel

 
Chief Warrant Officer 3
Stars! Nova developer
Stars! Nova developer

Messages: 179
Registered: April 2006
Location: Nowra, Australia
I just tried to launch the client with a new game and the main window fails to initialise. I know it has been a while since I touched the code. Is this a problem everyone is having? If so is anyone currently working towards getting Nova to at least do turns? Any timeline?




Have fun.

Report message to a moderator

Re: Can not launch client with a new game Tue, 14 February 2012 10:51 Go to previous messageGo to next message
Aeglos is currently offline Aeglos

 
Chief Warrant Officer 1
Stars! Nova developer
Stars! Nova developer

Messages: 142
Registered: May 2011
Location: Chile
I can launch the GUI no problems here. It could fail if you are continuing and old game as some things might have changed on the intel/order files. Discrd that, I just re-read your title. Are you getting any particular error?

I'm working towards making turns playable again, the thing is I ran into some GUI issues on editing waypoints from the WaypointList. As the GUI is right now, each time you change the speed for a waypoint it adjusts said data in real time. As we are moving to an orders system, each time you move the slider 1 unit it would generate a new edit waypoint order and add it to the commands queue. It could mean A LOT of unnesessary data blocks on the orders file when fine tuning travel times.

I was thinking of adding a "Confirm" button next to the slider to avoid this. Or else I'll code some parsing when writing the order file to discard multiple waypoint edits and leave the most recent one only.

I'm also changing the GUI WaypointList to use the Fleet's waypoint list as a DataSource or DataBinding (still deciding which), so instead of adding/removing everything manually two times (Once in a Fleet, a second time on the WaypointListBox) we just add it once to the fleet and the GUI reads that, as it should be.


[Updated on: Tue, 14 February 2012 10:56]

Report message to a moderator

Re: Can not launch client with a new game Tue, 14 February 2012 11:57 Go to previous message
Daniel is currently offline Daniel

 
Chief Warrant Officer 3
Stars! Nova developer
Stars! Nova developer

Messages: 179
Registered: April 2006
Location: Nowra, Australia
Never mind, it was something I did when getting the icon and title bars consistent. Embarassed Uploading the fix now.


Have fun.

Report message to a moderator

Previous Topic: rev 742 - Good and Bad on Mac OS X Lion with MonoDevelop 2.6
Next Topic: Production classes - IProductionUnit and derivates
Goto Forum:
  


Current Time: Wed Jul 28 07:16:39 EDT 2021