Home World Forum
Stars! AutoHost web forums

Jump to Stars! AutoHost


 
 
Home » Stars! 2.6/7 » Questions about Stars! AutoHost » Corrupt racefile
Corrupt racefile Thu, 30 July 2009 01:45 Go to next message
teefha is currently offline teefha

 
Crewman 2nd Class

Messages: 14
Registered: July 2009
Hiho

Iím new at autohost, and I intent to play here. Now I send johng316, the host in SAS3 my racefile, but he told me, its corrupt. I looked for the version, I play with some friends in my town 2,6i. I downloaded the gamefile STARS26JRC4.ZIP from http://www.starsautohost.org/kn2050.htm, following johns advise, recreated my race, but still corrupt.

Now my questions:
Witch version is the correct one here on autohost? (And where will i find it?)
Will 2 different versions make conflicts with the Stars-ini in the Systemdir?
What am i doing wrong?
Who can test my racefile after the new installation? (johng316 is away and he wanted to start the game, as soon as possible after he returns.)

Thx for any help and Greetings

teefha

Report message to a moderator

Re: Corrupt racefile Thu, 30 July 2009 03:16 Go to previous messageGo to next message
AlexTheGreat is currently offline AlexTheGreat

 
Lieutenant

Messages: 661
Registered: May 2006
Location: Sydney, Australia
correct version is 2.6jrc4 or 2.7jrc3

There is a bug in the race wizard. This is a copy of an email I sent to a player in an earlier game:

Hi,

Unfortunately, your race file is corrupt. You may or may not know the possible cause but it's usually because:

1. Incorrect version. Your Stars version should be 2.6jrc4 (or 2.7jrc3). If your version is something else then you can download 2.6jrc4 at http://starsautohost.org/files/stars26jrc4.zip. Note that there is no operational difference between 2.6jrc4 & 2.7jrc3 - 2.6 has no audio which I don't think anybody cares about anyway; I use 2.6 myself. Stars will ask you reenter your serial number after you upgrade.

2. There is a bug in the race wizard whereby, after you create your race, you then change it's name (I think it happens when the name is different to the original name by more than 1 letter). If that's the reason then you will be unable to load your race file in your own copy of Stars so it's a good idea to reload the race file after you've saved your final version to ensure it's OK.

John/AlexTheGreat


It's a good idea to jot down your race design just in case you have to recreate it.



[Updated on: Thu, 30 July 2009 03:21]

Report message to a moderator

Re: Corrupt racefile Thu, 30 July 2009 04:19 Go to previous messageGo to next message
teefha is currently offline teefha

 
Crewman 2nd Class

Messages: 14
Registered: July 2009
Thx to the fast answer.

1.) this file i downloaded in place in a new dir. It didn't ask me for my serial, i think, its becouse of ther is still a valis stars-ini-file.

2.) Thats i'm not sure. But it will try, it I'm at home.

At whom can I mail a testfile?

P.S.: Blue on black is a nice contrast Very Happy

Report message to a moderator

Re: Corrupt racefile Thu, 30 July 2009 09:51 Go to previous messageGo to next message
AlexTheGreat is currently offline AlexTheGreat

 
Lieutenant

Messages: 661
Registered: May 2006
Location: Sydney, Australia

You can PM the file to me or mail it to me at mcdonaldjk at bigpond dot com.

If it's corrupt though I still won't know why. The file should be OK provided it was created using the correct version of Stars & you can reload it (open the race file as if it were a turn file) afterwards.



Report message to a moderator

Re: Corrupt racefile Fri, 31 July 2009 04:58 Go to previous message
teefha is currently offline teefha

 
Crewman 2nd Class

Messages: 14
Registered: July 2009
funny, it should have been both problems. Wron verion first, an laterone the namechange. But now its working fine.

Thx for the help!

Report message to a moderator

Previous Topic: Frozen, without the usual message
Next Topic: SAH BACK ONLINE!!
Goto Forum:
  


Current Time: Sat Sep 30 06:16:51 EDT 2023